Más de 11 años en Internet
->No hagas click en esta frase.

15 octubre, 2012

Instalando Jelly Bean (CyanogenMod 10) en Folio 100


Desde principios de Septiembre está disponible en los foros de XDA-Developers la distribución CyanogenMod 10 compilada para la tableta Folio 100 de Toshiba. El artífice de tal acción no es menos que DerArtem, el que hiciere lo mismo a principios de año con la CyanogenMod 9. Para ser sinceros esta versión apenas trae novedades novedades respecto a su versión anterior, de hecho técnicamente su desarrollo aún no está finalizado, pero hay que remarcar que ahora se emplea Jelly Bean (Android 4.1)  como sistema operativo y que se ha añadido que en el futuro se pueda actualizar el sistema vía OTA

Al igual que su anterior versión en CyanogenMod 10 funciona casi todo el hardware del dispositivo, salvo el audio SCO a través de bluetooth, los botones táctiles de la derecha, el compás digital y el mando de control remoto. Además, en esta versión DerArtem vuelve a forzar en todo momento la presencia de la barra inferior para "ocultar" el problema de los botones táctiles. Tras varias semanas probándolo, lo único reseñable es que en ocasiones la wifi se queda frita, pero suele volver a funcionar tras reiniciar manualmente la conexión.

Instalando Clockworkmod Recovery 5.5.0.4

Ten en cuenta que puedes omitir este paso si ya instalaste en el pasado la Cyanogen Mod 9. De hecho, si en su día seguiste mi blog para instalar esa versión, notarás que esto es esta sección es un "copypaste". Bueno, la instalación de la rom es muy sencilla. A pesar de ello, para instalarla vas a tener que utilizar una versión especial del Clockworkmod Recovery modificada por el usuario nopy [1]. No vale el Clockworkmod Recovery que pudieras haber instalado con la Cyanogen Mod 7 o con el Recovery de Toshiba que venía de fábrica.
- Accede a esta entrada del foro y desde un ordenador bájate el archivo IMG. 
- Instala el SDK de Android en dicho ordenador. No nos hace falta que te descargues todas las API, símplemente verifica que el ejecutable fastboot esté presente en la carpeta platform-tools. 
- Enciende la tableta y en la propia pantalla de "Toshiba" (antes de que cargue Android), teclea la siguiente combinación: Power, power, power, volumen +. Sabrás que te ha salido bien porque te saldrá el siguiente texto: "Starting Fastboot USB download protocol, please execute 'fastboot' command". 
- A través de la salida micro-usb de la tableta, conéctala al ordenador a través de un puerto USB. 
- Abre una terminal y dirígete a la carpeta "platform-tools" del directorio donde has instalado el SDK de Android. 
- Desde esa terminal, teclea: fastboot flash recovery cwm-recovery-5.5.0.4.img. Eso sí, recuerda poner la ruta completa (o relativa) de donde se encuentre el cwm-recovery-5.5.0.4.img. Si no lo haces, el fastboot se pensará que el archivo cwm-recovery-5.5.0.4.img se encuentra en la carpeta "platform-tools". 
- Una vez finalice el fastboot (debería de ser un proceso rápido), desconecta el cable USB y reinicia la tableta.

/* Actualización 08/11/2012 */

Desde la versión Alfa 3 se recomienda la instalación de otra versión del Clocworkmod, concrétamente la imagen "recovery-cwm-CM10-A3.img", disponible en el siguiente enlace: http://forum.xda-developers.com/showpost.php?p=30988436&postcount=1. Luis, gracias por el aviso.


Instalando CyanogenMod 10
Dirígete a esta entrada del foro y descárgate la última versión disponible. En la actualidad es la "Alpha 3", pero no sería descabellado que exista otra versión cuando leas estas líneas. Verás que se trata de un comprimido "zip" que deberás de copiar tal cual (sin descomprimir) dentro de una tarjeta SD.

Enciende la tableta y pulsa a la vez el botón power y el volumen+. A la primera pregunta responde con volumen+, después con volumen- y a la última con volumen+. Acto seguido te arrancará el Clockworkmod Recovery. Inserta la tarjeta SD en la tableta (si no la tenías puesta ya) y selecciona "install zip from sdcard" (podrás moverte con volumen+ y volumen-, pulsa power para seleccionar opciones). Acto seguido selecciona "Choose zip from sdcard" y navega hasta seleccionar el zip que contiene el CyanogenMod 10.

Una vez acabada la instalación, selecciona "Go Back" y realiza un "wipe data/factory reset" y un "wipe cache partition", puesto que es imprescindible para que el primer arranque no sea un bucle infinito. Estas acciones borrarán todos los datos que hayas podido almacenar en la tableta. Por último selecciona "reboot system now". Enhorabuena, ya tienes instalada tu CyanogenMod 10.


(Las coronas las he pegado para ocultar el ID de mi dispositivo).

Instalando las Google Apps
CyanogenMod 10 viene por defecto sin las aplicaciones de Google Play, GMail, etc... pero puedes instalarlas de forma manual. Accede a esta entrada del foro de XDA Developers y descárgate el archivo "gapps-jb-20120726-signed.zip". Cópialo a una tarjeta SD, reinicia la tableta y arranca el Clockworkmod Recovery. Selecciona "install zip from sdcard> Choose zip from sdcard" y navega por la tarjeta SD hasta encontrar el "gapps-jb-20120726-signed.zip".

Por cierto, a diferencia de CM9 podrás instalar Google Chrome a la primera, sin tocar nada, pero no recomiendo utilizarlo porque este navegador se muestra muy inestable en esta tableta.

69 comentarios:

  1. Hola, segui los pasos al pie de la letra, y parecia que todo estaba correcto (el paso del fastboot, entrar al recovery nuevo, instalar el archivo desde el zip de una SD, al finalizar hacer los dos wipe que comentas en el mismo orden), pero cuando reinicie la tablet, aparece el logo de toshiba, y luego la pantalla se queda en negro. He comprobado que puedo entrar al recovery, y probe a repetir los pasos...pero nada, sigue igual. Que deberia hacer?, gracias por tu ayuda

    ResponderEliminar
  2. Hola de nuevo... al final consegui arreglar el tablet... no se si es que no leyo bien la memoria o que, pero repeti los pasos lentamente y uno a uno, y al final lo consegui. :)

    ResponderEliminar
  3. Hola @Anónimo. Si bien no recuerdo la primera vez que arrancas con el sistema nuevo el tiempo de carga es varios minutos más largos debido a un copiado de archivos, luego podría ser esa la razón de la pantalla en negro que comentabas.

    Un saludo

    ResponderEliminar
  4. Gracias por la explicación, General. Intenté instalar cyanogenmod 10 tras haber instalado la 9 (también gracias a tu how-to), pero al arrancar se quedaba en negro una vez desaparecía el logotipo de Toshiba. Esperé al menos 10 minutos tras el inicio para comprobar si era el mismo caso que en los comentarios arriba. Pero no obtuve ningún resultado favorable. En el How-to de xda-developers he creido leer que se necesita un nuevo formateo de la sd interna con el formatsd.zip descargable desde su página para poder instalar la versión 10 a partir de la version alfa 2. Para aquellos que entraron en esta página tan pegados como yo, sólo recordar que es necesario una nueva versión de ClockWorkMod Recovery, una nueva rom o imagen y un nuevo zip de gapps (para goolge apps). Y no sé si esw necesario instalar previamente las versiones alfa 2 y 3 para instalar la 4, ésta última la versión más reciente a la fecha de este post.

    Gracias de nuevo, general.

    ResponderEliminar
  5. Hola @Anónimo. Como bien comentas hay que hacer un wipe completo, es decir, desde el Recovery hay que realizar un formateo de particiones completo. Además de requerrir instalar unas Google Apps distintas a las facilitadas en la CM9.

    En mi caso no necesité una versión nueva del ClockWorkMod, pude instalar la Aplha 3 a partir del utilizado para la CM9.

    Un saludo,
    Sebas

    ResponderEliminar
  6. Hola,
    Muchas gracias, por el tutotial!

    Yo me he instalado el Aplha 4 y al hacerlo con el recovery que nos recomendabas, después de instalar, al arrancar se me quedaba la pantalla en negro...

    He probado un par de cosillas y al final lo he conseguido instalando el recovery que recomiendan en el foro para las Alphas 3 y 4 "recovery-cwm-CM10-A3.img"

    Y ya tengo mi folio renacida!!
    Muchas gracias de nuevo!!

    Luis.

    ResponderEliminar
  7. Ok, gracias Luis. Actualizo la entrada con tu aporte.

    ResponderEliminar
  8. Hola, Por desgracia he comprado una toshiba folio 100, y no se ve youtube,bueno instalandolo desde aptoide si,pero desde el navegador google no se ve, a parte de que se queda "petada muchas veces, puedo hacer este tutorial sin correr riesgos?

    ResponderEliminar
  9. Hla, como se puede hacer una copia de seguridad desde la folio 100, por si algo me sale mal?

    ResponderEliminar
  10. hola tengo una pipo smart-1 y no me pasa del logotipo de pipo,he probado que entre en recovery y no lo consigo, tambien con Upgrading Tool 1.5 y en este programa cuando me detecta la tablet el cuadrado numero1 se pone rosa en vez de verde,por fabor una ayudita.

    ResponderEliminar
  11. hola, tengo un problema y es que cuando intento dar a CHoose zip from sdcard, me dice que no la puede montar. He instalado alpha 4.
    Cual podría ser el problema.
    gracias

    ResponderEliminar
  12. Hola, soy la del comentario anterior. Ya sé lo que me ha pasado y quiero dejarlo aquí por si alguien tiene el mismo problema. En vez de pulsar en choose zip sd- card hay que hacerlo en choose zip from external sd-card. Y para las google apps igual (siempre que tengais el CVM version 6.0.1.5.
    Yo ya la tengo corriendo Jelly Bean!! Gracias por todo

    ResponderEliminar
  13. Hola, yo tambien he instalado Jelly Bean con Alpha 4. Me va todo perfecto, la verdad es que parece que tengo una tablet nueva. El único problema es que es imposible montar la SD-interna. No se si se me hay algun comando que pueda utilizar o si es que me he saltado algun paso. Si alguien puede ayudarme se lo agradecería.
    Muchas gracias

    ResponderEliminar
  14. el PC tampoco la reconoce y he intentado hacerlo desde el recovery y tampoco!! no sé qué mas hacer

    ResponderEliminar
  15. A mi me pasa lo mismo, tengo corriendo CM10 pero no me reconoce ni la SD interna ni la externa

    ResponderEliminar
  16. Hola, ante todo felices fiestas. bueno yo tengo una folio 100 y he decidido regalarla, pero antes quiero remozarla un poco para dejarla decentita y googleando he llegado hasta aquí. Todo lo explicado es muy sencillo pero el caso es que yo uso ubuntu quantal y para cambiar el recovery he instalado desde los repositorios esto:

    sudo apt-get install android-tools-fastboot

    luego he hecho lo del pwer pwer pwer y vol+ para entrar en fastboot protocoll y he escrito desde el ordenador en la linea de ordenes esto para asegurarme que reconocia el dispositivo:

    sudo fastboot devices

    Y luego al poner esto:

    sudo fastboot flash recovery /home/usuario/recovery-cwm-CM10-A3.img

    me devuelve:

    sending 'recovery' (4342 KB)...
    FAILED (command write failed (Protocol error))
    finished. total time: 0.004s

    Y en el tablet me dice "fallo al procesar el comand getvar:max-dowload-size error..."

    Creo que como es una orden para win2 simplemente es que no funciona en ubuntu y ya he probado varias cosas mirando la ayuda pero temo meter la pata y poner el tablet en modo ladrillo, por eso pido ayuda pues no estoy muy experimentada en el manejo de la consola, además no dispongo de otro OS para hacer la tarea y espero solucionar este problema con mi linux antes que pedir prestado un win2 a alguien.
    Un saludo y gracias

    ResponderEliminar
  17. Hola @gema, no es una orden de Win2, la instalación la he realizado desde un Linux. Por el error parece un problema de comunicación entre el dispositivo y el ordenador. Puede que el SDK de Android que has instalado no reconoce bien el dispositivo en Linux.

    Por lo que veo en Google, gente que ha tenido el mismo problema que tu lo ha arreglado ejecutándolo desde Windows.

    ResponderEliminar
  18. Hola. Si, instalé el paquete de los repositorios de ubuntu y no el sdk del enlace que das en el tuto, mas que nada por comodidad. Si tal como dices parece ser un problema del soft, probaré a instalar el indicado mas arriba y seguir las instrucciones al pié de la letra, a ver como va.
    Aclarar por si sirve de algo que a esa tablet le instalé una de las primeras roms que sacaron para ella, justo antes de que los impresentables de toshiba sacaran aquella actualización que dificultaba muchísimo la instalación de roms nuevas.
    Yo cometí el error de actualizar con la herramienta de tshiba desde la rom instalada y luego me enteré por los foros de por que la lié, pero ya era tarde. Aun así como todo parecía funcionar mas o menos a trompicones, lo dejé estar y así he tenido la folio hasta hoy, que tengo un cacharro que lleva un OS de ****** sobre un hardware mas o menos decente, y que necesita si o si esta actualización.
    Muchas gracias por responder, Si lo consigo iré colocando aquí mis progresos.
    Un saludo

    ResponderEliminar
  19. sabeis desde donde me puedo descargar el archivo Clockworkmod Recovery modificada por el usuario nopy ya que en la pagina principal no funciona ningun enlaze

    ResponderEliminar
  20. el tutorial está de pxxx madre salvo que llevo todo el día intentando instalar el sdk y me dice que no encuentra el archivo android.bat de dios... a alguien le pasó lo mismo?? Muchas gracias...

    ResponderEliminar
  21. buen tutorial pero no apto para novatos, muy complejo... cuando subais estas cosas pensad que hay quien necesita todo paso a paso. Gracias.

    ResponderEliminar
  22. Buenos días, enhorabuena por el blog. Tengo una folio 100 he realizado los que vas comentando pero me pone que no tengo drivers de fastboot, me los he bajado pero no se instalarlo... algún consejo. Gracias.

    ResponderEliminar
  23. saludos a la comunidad. Tengo un problema Sebastián y es que cuando hago fastboot flash recovery xxxxx me dice la tablet que hay un error, 0x02, el pc pone failed (command write faile (invalid argument)) al final creo a la gente del foro que lo mejor es llevarla a un informático...Tengo el mismo problema que Gema pero yo estoy con el windows 7..¿? Help!!!! Help!!!!
    Para anónimo del 2 de enero, en este mismo tuto te puedes bajar lo que buscas, lee bien que aparece el enlace en actualización 8/11/12. Gracias a quien responda de antemano.

    P.D. Entre todos podemos...

    ResponderEliminar
  24. @Anónimo fastboot va incluido dentro del SDK de Android, no hace falta instalarlo. Al menos en Linux es símplemente abrir un intérprete de comandos (cmd en Windows) y dirigire a la ruta del ejecutable para poder hacer uso de él. Si se queja por drivers pudiera ser cosa del cable que usas, puesto que con él no está reconociendo tu dispositivo. Puedes darle un vistazo a este enlace http://forum.xda-developers.com/showthread.php?t=1119507, facilitan un android_winusb.inf modificado que pudiera servirte.

    @Jesús el problema de Gema se solventó resintalando el SDK de Android. Por el tipo del literal del error diría que es el comando el que has escrito mal, revisa que cuando escribas el comando estés pasando la ruta del archivo img de forma correcta.

    ResponderEliminar
  25. Sebastian gracias por responder, instalare de nuevo el sdk y escribire la ruta con mucho cuidado. A ver si al final lo consigo... esto es un poco dificil... saludos y gracias nuevamente..

    ResponderEliminar
  26. Bueno lo he intentado de nuevo desde win 7. Cogí y renombré el archivo a cwxxx. img a3.img mucho más fácil de escribir y lo copié dentro de la carpeta platform-tools para evitar tener que escribir la ruta. Reinstalé de nuevo el sdk. El resultado el mismo, no funciona. Así que no sé qué más probar, alguna idea? Gracias...
    P.D. Creo que usaré la tablet para ver el correo y como dice un compañero del foro... ver recetas de cocina, pero en video no, que no puedo... vaya tablet, y vaya con los de toshiba...

    ResponderEliminar
  27. Por cierto Sebastian, cada vez que pinchamos en un enlace se abre en tu misma pestaña, lo mismo sería mas recomendable que se abriese en otra y así tener la tuya accesible. Esto es tan solo una opinión. Gracias

    ResponderEliminar
  28. Gracias gracias gracias gracias gracias gracias...

    ResponderEliminar
  29. @Jesús, el problema abrir los vínculos en una pestaña externa es que no es algo "estándar" en html, e incluso en determinados navegadores lo malinterpretan como abrir una ventana nueva.

    Respecto a tu problema, se ve que tienes instalada una actualización oficial que bloquea la instalación de roms caseras de forma remota. Por lo que leo en XDA (http://forum.xda-developers.com/showthread.php?t=2022084) la gente con este problema copia el archivo img dentro de la raíz de la tarjeta externa SD, mete la tarjeta en la tableta, arranca en modo fastboot(Power, power, power, volumen +) y ejecutas desde el terminal de tu PC: fastboot boot a3.img

    ResponderEliminar
  30. Poco a poco... Nuevamente agradecer tu ayuda. Por fin hay algo que sale, ha aparecido la pantalla del recovery nuevo, menos mal. Hice todo lo que me recomendaste y salió, pero ahora me dice que no puede montar la tarjeta... ¿? Al final si le instalo el sistema, Sebastián, y eres del sur... nos vamos de tapas que pago yo... je je je... madre mía la que está dando. Soy profesor de matemáticas y queda claro, cada uno a los suyo, esto de las tablets... no es lo mío. Un compañero de departamento tiene otra tablet y al final a ido a un informático para que se lo instale, a ver si con tu ayuda puedo... Mil gracias y un saludo.

    ResponderEliminar
  31. Hola Jesús, intenta hacer esto que he encontrado aquí (http://forum.xda-developers.com/showpost.php?p=31004271&postcount=9), poniendo el img en el mismo directorio que el fastboot:

    fastboot erase recovery
    fastboot flash recovery recovery-cwm-CM10-A3.img
    fastboot reboot

    Si lo haces desde un linux, acuerdate de poner antes "sudo ./", quedando así: "sudo ./fastboot...".

    Una vez accedas, navega por los menos para montar la "external sd" y selecciona los zip del "external sd card".

    Suerte

    ResponderEliminar
  32. Buenas, tengo la toshiba folio 100 rooteada desde hace unos meses que leí este tutorial, EL UNICO PROBLEMA,es que cuando la enciendo tarda un rato en conectarse, otras veces a la primera, puede ser que haya echo algo mal? TAMBIEN DICE QUE NO HAY TARJETA SD INTEGRADA Y NO DEJA INSTALAR NADA,que no sea del playstore He buscado actualizarla via O.T.A. pero me pone que no hay mas actualizaciones (cyanogenmod10)

    ResponderEliminar
  33. Hola @Anónimo. Lo de la wifi puede pasar, pero lo de la SD integrada es muy raro. Si no tienes estima al contenido que tengas almacenado, prueba a hacer un "wipe data/factory reset" y un "wipe cache partition".

    ResponderEliminar
  34. Soy anonimo otra vez, Si hago eso tendré que rootear otra vez la tablet, y lo del complemento de google y aplis extras se me borraran??No tengo problemas en el demas contenido que se pueda borrar.
    MUCHISIMAS GRACIAS.

    ResponderEliminar
  35. Hola me llamo Antonio y tengo una Folio 100 con el Foliomod.v1.4 y la quiero cambiar a la cyanogenmod.10. Me he descargado todos los Zip que piden, pero no tengo ni idea de como emprezar a instalarlo, y la explicaciones que se dan son un poco confusas. Por favor si alguien me lo puede explicar paso a paso. Gracias.

    ResponderEliminar
  36. Buenas, soy Jesús, al final lo dejé por imposible. Acabo de ver que salió la 4.2.2 jelly bean el 17 de febreo... quizás con ésta si que se pueda... saludos... y muchas gracias por todo Sebastián.

    ResponderEliminar
  37. Hola soy nuevo en esto, pero me guataria saber si alguien me puede ayudar. Al Ejecutar fastboot flash recovery cwm-recovery-5.5.0.4.img me sale el siguiente mensaje "waiting device", y no puedo continuar.

    Gracias
    JM

    ResponderEliminar
  38. Vale soy JM y ya he solucionado el comentario anterior "waiting device", pero ahora me pone failed command write failed (no such device or address), por favor me podeis ayudar, gracias

    JM
    Salu2

    ResponderEliminar
  39. Buenos dias.Igual esto te puede ayudar::
    http://www.pixelom.com/?p=271

    ResponderEliminar
  40. Buenas. Tengo rooteada la tablet y al igual que anómino 18/02 me pone que no puede montar tarjeta interna. Por lo tanto no puedo usar la cam, ademas el recovery ese que se usa para instalar la room tampoco la puede montar... Alguien con conocimientos y ganas puede ayudarnos??
    Muchas gracias.

    ResponderEliminar
  41. Hola compañero!!!
    Eres un crack, esta todo muy bien explicado y funciona de maravilla, le he devuelto la vida a mi tableta.
    muchas gracias

    ResponderEliminar
  42. Alguien podría decirme como descargar los archivos en rapidshare parece que ya no estan.
    Muchas Gracias

    ResponderEliminar
  43. @Anónimo, realiza las descargas a partir de los enlaces del foro: http://forum.xda-developers.com/showthread.php?t=1864774

    ResponderEliminar
  44. Hola!! hace falta estar rooteado para hacer esta tutorial

    ResponderEliminar
  45. y lo de abrir una termimal?? me lo podrias esplicar mejor.. MUCHAS GRACIAS SE AGRADECE TODO LO QUE HACEIS PARA MEJORAR LAS INJUSTICIAS QUE NOS VENDEN

    ResponderEliminar
  46. Muchas gracias Sebastián agradecerte desde el anonimato tu respuesta a mi pregunta y a este magnifico blog un abrazo

    ResponderEliminar
  47. hola sebastian!!! por favor me podrias decir que tengo que escribir en el terminal ( simbolo del sistema )despues de llegar a la carpeta platform-tools\fastboot...si tengo el recovery en el escritorio,o tengo que darle al enter en fastboot y dspues buscar la ruta del recovery. MUCHAS GRACIAS.

    ResponderEliminar
  48. Hola Miguel. Mi consejo es que si no estás seguro de los pasos a seguir, no los hagas. El tutorial parece sencillo, pero ten en cuenta que si cometes un error te puedes quedar sin tableta.

    Respondiendo a tu pregunta, copia el archivo "recovery-cwm-CM10-A3.img" al directorio del platform-tools y en el terminal/simbolos del sistema ejecuta "fastboot flash recovery recovery-cwm-CM10-A3.img".

    ResponderEliminar
  49. Eso te permitirá instalar el recovery, después debes de seguir los pasos del tutorial: Copiar la imagen de la alfa 5 a la SD, instalar a través del recovery y wipear.

    ResponderEliminar
  50. Por cierto, el comentario de "Mi consejo es que si no estás seguro de los pasos a seguir, no los hagas" no va dirigido especialmente a Miguel, es una advertencia general para concienciar un poco.

    Venga, ánimo y suerte con la tableta =)

    ResponderEliminar
  51. MUCHAS GRACIAS SEBASTIAN!!! lo he intentado pero me da error (no such file or directory ) No existe el fichero o directorio. De nuevo muchas gracias por contestar tan rapido. Un saludo.

    ResponderEliminar
  52. Escribe "fastboot.exe flash recovery recovery-cwm-CM10-A3.img", a ver si es la terminal de Windows que requiere que le digas la extensión del ejecutable.

    Recuerda haber hecho la copia del archivo img al directorio de platform-tools para facilitar la tarea, y de haber accedido a ese directorio a base de comandos "cd".

    ResponderEliminar
  53. Tened en cuenta que se necesita si o si tener la tablet rooteada para poder flashear el recovery.

    Aquí hay un tuto de cómo hacerlo:
    http://theunlockr.com/2012/09/19/how-to-root-the-toshiba-folio-100/

    ResponderEliminar
  54. Menudo tutorial! Mi enhorabuena!!

    Espero que puedas responderme una duda: ¿si instalo el Clockworkmod Recovery 5.5.0.4 en formato Zip desde el recovery de la propia Tablet funcionará o blick?

    Un saludo! Aquí un nuevo seguidor de tu blog.

    ResponderEliminar
  55. David, en caso de duda no lo hagas, hay cosas para las que la humanidad aún no está preparada. En todo caso tendrás que instalarlo como un system update y si tu tablet está rooteada. Si no está rooteada no se aplicará.

    ResponderEliminar
  56. Hola a todos. Soy Javier
    Una pregunta... Cuando quiero instalar la versión Jelly Bean / CM10 (4.1.2) Alpha 5 - 3.1 kernel
    Copia formatsd.zip y recovery-cwm-6.0.1.4.img en la tarjeta sd y la pongo
    Desde el CMD ejecuto fastboot erase userdata
    Bueno, pues ahí llego. Me sale en la pantalla de la tabla el mensaje
    "Failed to process command getvar: partition-type: userdata error (0x2)

    Y no puedo avanzar. Si eres tú , Sebastián, o cualquiera tan amable de darme una solución, lo agradecería
    Un saludo

    ResponderEliminar
  57. Sigo mi comentario. Soy Javier
    Si no supierais la solución a mi problema, ¿alguién podría facilitarme el Clockworkmod Recovery 5.5.0.4? Es que en la página xda se ha caído el enlace.
    Yo creo que sería una solución

    ResponderEliminar
  58. @Javier Instálate esta versión de CM y CW Recovery http://forum.xda-developers.com/showthread.php?t=2152095

    Es una versión más actualizada, funciona mejor y los enlaces no están caídos.
    Saludos

    ResponderEliminar
  59. Si. Lo sé Sebastián. Pero el problema es que cuando quiero instalar el recovery, al ejecutar el fastboot, siempre me da el mismo error. Failed to process command getvar: partition-type: userdata error (0x2)
    De ahí que pidera lo del 5.5.0.4, porque cuando lo hice la anterior vez no tuve problema alguno

    Creo que hay que formatear la memoria interna de la tablet antes con el archivo formatsd. Lo pongo en la tarjeta sd externa, pero ¿cómo lo hago?

    ResponderEliminar
  60. Javier.
    Bueno... Ya encontré la solución en los foros de XDA
    Ya resuelto. El problema era que el fastboot no detectó mi tableta. Cuando hago fastboot devices obtengo:
    ? fastboot.
    Con todo adb es OK!
    En los comandos de fastboot erase, flash, etc, nada funcionaba. Excepto reinicio.
    La única manera era: boot fastboot recovery.img
    (pero el archivo recovery.img lo puse en el mismo directorio de fastboot)
    Al instante tenía instalado el recovery CWM v6.0.2.8

    Pongo todo esto por si le sirve a alguien. O algún pesado como yo te pregunta
    Gracias por mantener este blog de la Folio 100

    ResponderEliminar
  61. Buenas gente, salió todo muy bien el unico inconveniente que estoy teniendo es que no puedo conectarla a traves de un usb al pc, funciona perfecto todo pero alguien me daría una mano y explicarme como hago para que mi pc la reconozca como disco externo? Gracias

    ResponderEliminar
  62. Lo consegui despues de abandonar este artilugio durante mas de un año. A ver si le saco provecho.
    Muchas gracias.

    ResponderEliminar
  63. Hola Sebastian, estoy intentando usar tu procedimiento y al ejecutar el comando 'Fastboot flash recovery' me sale el error 'waiting for device', he visto que a otro usuario le ha pasado lo mismo pero no dice como lo ha solucionado, te agradecería muchísimo si pudieras echarme una mano y decirme que hay que hacer.

    Otra pregunta, ¿hay que ser root para instalar CyanogenMod 10?

    Muchísimas gracias por anticipado.

    JR

    ResponderEliminar
  64. Hola JR, hay que ser sudoer o root para poder instalar la imagen, espero que te sea de ayuda.

    ResponderEliminar
    Respuestas
    1. Hola otra vez Sebastián, no consigo rootear la Folio, me da que no tengo los drivers instalados en W7, con USB debugging ON no veo el dispositivo en W7. he probado varios métodos para instalar los drivers pero nada, te agradecería mucho si puedes decirme alguna sugerencia de como proceder.

      Gracias otras vez.

      JR

      Eliminar
    2. Por lo que veo no eres el único que ha tenido problemas con Windows 7. Perdona si la pregunta es obvia, pero ¿has probado a arrancar el intérprete de comandos (cmd) como administrador (a través del menú inicio, click derecho "ejecutar como administrador")?

      Eliminar
    3. SOLUCIONADO TODOS MIS PROBLEMAS GRACIAS A SEBASTIAN; AL EQUIPO DE XDA, A CWMod & CMod, etc..
      AÑADIENDO ESTO (arrancar desde el archivo de cwm y no intentar recovery):
      en terminal despues de entrar en la carpeta "platform-tools" con los comando "cd"
      teclee: ./fastboot boot recovery-cwm-CM10-A3.img
      y funciono! Arranco el programa para instalar desde ExtSD el ZIP
      AHORA TENGO LA MALDITA FOLIO 100 COMO NUEVA para mi hijo.
      GRACIAS GRACIAS GRACIAS

      Eliminar
  65. hola buenas, tengo un poco de lio con todo esto, mi tablet folio 100 tiene configuración de fábrica, me bajé el CM 10, alpha 5, con su recovery en .img, y ahí me he quedado, por que al meter la tarjeta en la tablet las indicaciones que me dan no coinciden con ninguna que haya visto por ahí, me dice que no encuentra el archivo y no me da opción de buscar dentro de la SD, no se si debería instalar primero otra versión, o que estoy haciendo mal.. espero que alguien pueda ayudarme

    ResponderEliminar